summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTomasz Figa <[email protected]>2016-12-14 17:00:27 +0900
committerEmil Velikov <[email protected]>2017-01-18 13:25:17 +0000
commit2d14ae6bea4af444ca77e9f6e7d3898a3f39b2d3 (patch)
treeb62631575727023163f6d9ed9b8fb06292790f4d /configure.ac
parent1a0aa468f354f0ee94dd383cd40ae915584624aa (diff)
configure.ac: Respect LLVM_CFLAGS in LLVM version detection
When compiling LLVM headers, including llvm-config.h, we need to respect LLVM_CFLAGS. This is especially crucial if LLVM is located in a non-standard location and it happens that llvm-config.h includes another header. In such case the detection would fail due to missing header, because the path is provided in LLVM_CFLAGS. Let's add LLVM_CFLAGS to global CFLAGS for the time of detection and then restore the original flags, as done in other places of the script. Signed-off-by: Tomasz Figa <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 655b76ed6e6..182d0726c30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -979,6 +979,10 @@ llvm_set_environment_variables() {
LLVM_INCLUDEDIR=`$LLVM_CONFIG --includedir`
LLVM_LIBDIR=`$LLVM_CONFIG --libdir`
+ # We need to respect LLVM_CFLAGS when compiling LLVM headers.
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $LLVM_CFLAGS"
+
AC_COMPUTE_INT([LLVM_VERSION_MAJOR], [LLVM_VERSION_MAJOR],
[#include "${LLVM_INCLUDEDIR}/llvm/Config/llvm-config.h"])
AC_COMPUTE_INT([LLVM_VERSION_MINOR], [LLVM_VERSION_MINOR],
@@ -986,6 +990,8 @@ llvm_set_environment_variables() {
AC_COMPUTE_INT([LLVM_VERSION_PATCH], [LLVM_VERSION_PATCH],
[#include "${LLVM_INCLUDEDIR}/llvm/Config/llvm-config.h"])
+ CFLAGS="$save_CFLAGS"
+
# Only needed for LLVM < 3.6.0
if test -z "$LLVM_VERSION_PATCH"; then
LLVM_VERSION_PATCH=0