summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rowley <[email protected]>2017-07-07 13:58:09 -0500
committerTim Rowley <[email protected]>2017-07-19 15:12:07 -0500
commit1cb5a6061ce4b7f0cf5a9e5938bc1a11fe24b9ca (patch)
treedacc5d03adf64e6054a8ebcfb18f7d310bb20822 /configure.ac
parentf42186b01dbc78357ace1bf47feb69696471b580 (diff)
configure/swr: add KNL and SKX architecture targets
Not built by default. Currently only builds with icc. v2: * document knl,skx possibilities for swr_archs * merge with changed loader lib selection code Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cfc53de608e..38cd1271ecf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2357,7 +2357,7 @@ dnl Architectures to build SWR library for
AC_ARG_WITH([swr-archs],
[AS_HELP_STRING([--with-swr-archs@<:@=DIRS...@:>@],
[comma delimited swr architectures list, e.g.
- "avx,avx2" @<:@default="avx,avx2"@:>@])],
+ "avx,avx2,knl,skx" @<:@default="avx,avx2"@:>@])],
[with_swr_archs="$withval"],
[with_swr_archs="avx,avx2"])
@@ -2521,6 +2521,20 @@ if test -n "$with_gallium_drivers"; then
AC_SUBST([SWR_AVX2_CXXFLAGS])
HAVE_SWR_AVX2=yes
;;
+ xknl)
+ swr_require_cxx_feature_flags "KNL" "defined(__AVX512F__) && defined(__AVX512ER__)" \
+ ",-march=knl,-xMIC-AVX512" \
+ SWR_KNL_CXXFLAGS
+ AC_SUBST([SWR_KNL_CXXFLAGS])
+ HAVE_SWR_KNL=yes
+ ;;
+ xskx)
+ swr_require_cxx_feature_flags "SKX" "defined(__AVX512F__) && defined(__AVX512BW__)" \
+ ",-march=skylake-avx512,-xCORE-AVX512" \
+ SWR_SKX_CXXFLAGS
+ AC_SUBST([SWR_SKX_CXXFLAGS])
+ HAVE_SWR_SKX=yes
+ ;;
*)
AC_MSG_ERROR([unknown SWR build architecture '$arch'])
;;
@@ -2528,7 +2542,9 @@ if test -n "$with_gallium_drivers"; then
done
if test "x$HAVE_SWR_AVX" != xyes -a \
- "x$HAVE_SWR_AVX2" != xyes; then
+ "x$HAVE_SWR_AVX2" != xyes -a \
+ "x$HAVE_SWR_KNL" != xyes -a \
+ "x$HAVE_SWR_SKX" != xyes -a; then
AC_MSG_ERROR([swr enabled but no swr architectures selected])
fi
@@ -2571,6 +2587,8 @@ fi
AM_CONDITIONAL(HAVE_SWR_AVX, test "x$HAVE_SWR_AVX" = xyes)
AM_CONDITIONAL(HAVE_SWR_AVX2, test "x$HAVE_SWR_AVX2" = xyes)
+AM_CONDITIONAL(HAVE_SWR_KNL, test "x$HAVE_SWR_KNL" = xyes)
+AM_CONDITIONAL(HAVE_SWR_SKX, test "x$HAVE_SWR_SKX" = xyes)
dnl We need to validate some needed dependencies for renderonly drivers.