summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-12-08 03:03:40 +0100
committerEmil Velikov <[email protected]>2017-01-18 13:23:01 +0000
commit1a0aa468f354f0ee94dd383cd40ae915584624aa (patch)
tree844a917869927092c3ced52e98ad91f19fb9f1b1 /configure.ac
parent4d0efb9683856cada2f34b124c77ef20a2fe0332 (diff)
configure.ac: Don't check LLVM version in gallium_require_llvm
This is actually not needed because the version is checked later. Line 2609: if test "x$enable_gallium_llvm" == "xyes"; then llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium" llvm_add_default_components "gallium" HAVE_GALLIUM_LLVM=xyes DEFINES="${DEFINES} -DHAVE_GALLIUM_LLVM" fi Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5740da6ee91..655b76ed6e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2387,9 +2387,7 @@ dnl
dnl Gallium helper functions
dnl
gallium_require_llvm() {
- if test "x$enable_gallium_llvm" = "xyes"; then
- llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
- else
+ if test "x$enable_gallium_llvm" != "xyes"; then
AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
fi
}