summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rowley <[email protected]>2017-06-08 10:38:52 -0500
committerTim Rowley <[email protected]>2017-06-08 18:07:52 -0500
commit0b80b025021f97d27520390867c20336dc891a16 (patch)
treed73ae79685083f6d9fa36de43f3f21434707fa9a /configure.ac
parenta625d58ee19cd9f88af2ee76de604420c39f5afb (diff)
swr: relax c++ requirement from c++14 to c++11
Remove c++14 generic lambda to keep compiler requirement at c++11. No regressions on piglit or vtk test suites. Tested-by: Chuck Atkins <[email protected]> Reviewed-by: Bruce Cherniak <[email protected]> CC: [email protected]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5caf316089a..82a1bd6cd1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2472,10 +2472,10 @@ if test -n "$with_gallium_drivers"; then
xswr)
llvm_require_version $LLVM_REQUIRED_SWR "swr"
- swr_require_cxx_feature_flags "C++14" "__cplusplus >= 201402L" \
- "-std=c++14" \
- SWR_CXX14_CXXFLAGS
- AC_SUBST([SWR_CXX14_CXXFLAGS])
+ swr_require_cxx_feature_flags "C++11" "__cplusplus >= 201103L" \
+ ",-std=c++11" \
+ SWR_CXX11_CXXFLAGS
+ AC_SUBST([SWR_CXX11_CXXFLAGS])
swr_require_cxx_feature_flags "AVX" "defined(__AVX__)" \
",-mavx,-march=core-avx" \