summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGurchetan Singh <[email protected]>2016-10-27 09:06:42 -0700
committerEmil Velikov <[email protected]>2016-11-15 15:48:02 +0000
commite23608db1cad3d3b86b5350255db4d47a0081d2e (patch)
tree287e4c0587ce8b8c256bfc060904ce3383beed24 /configure.ac
parente73513f3c85f45a05a23dbdcda7901812fc4d4fa (diff)
configure.ac: Don't look for pthreads in Android platform
In Android, the pthreads libs are in bionic. When building Mesa for Android with the autotools workflow, we shouldn't set -lpthread or -pthread. [Emil Velikov] Other platforms could use a similar fix, although that is left as separate exercise. Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4761c5972e8..3f21cd53a76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -823,8 +823,11 @@ if test "x$ax_pthread_ok" = xno; then
fi
dnl AX_PTHREADS leaves PTHREAD_LIBS empty for gcc and sets PTHREAD_CFLAGS
dnl to -pthread, which causes problems if we need -lpthread to appear in
-dnl pkgconfig files.
-test -z "$PTHREAD_LIBS" && PTHREAD_LIBS="-lpthread"
+dnl pkgconfig files. Since Android doesn't have a pthread lib, this check
+dnl is not valid for that platform.
+if test "x$android" = xno; then
+ test -z "$PTHREAD_LIBS" && PTHREAD_LIBS="-lpthread"
+fi
dnl pthread-stubs is mandatory on targets where it exists
case "$host_os" in