summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-01-11 19:02:26 -0500
committerMatt Turner <[email protected]>2012-01-20 14:56:14 -0500
commit2fdbbeca43e7b57095774e4228e6eea75a180fab (patch)
treeb66fde3d38f265e0a71f774fc4266b04946dcbff /configure.ac
parentba5252e590782a77b8a46d9c0ec4691cf8da6298 (diff)
Remove -ffast-math from default CFLAGS
Fixes glsl-const-folding-01. inversesqrt(1.0) != 1.0 was evaluating as true. Signed-off-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f3f5e3e94d2..e13c4cfc57f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,9 +176,6 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99"
- if test "x$CLANG" = "xno"; then
- CFLAGS="$CFLAGS -ffast-math"
- fi
# Enable -fvisibility=hidden if using a gcc that supports it
save_CFLAGS="$CFLAGS"