summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2011-06-22 11:35:27 -0700
committerIan Romanick <[email protected]>2011-07-11 15:02:16 -0700
commitdb311b45beb60630ad3e3c803631c2b6c1472347 (patch)
tree3b00e59bb1abf73186ce574ed8e5c7b05d991834 /configure.ac
parent2df4b6117b27acb4ea46222b47353ffb9f513204 (diff)
configure.ac: Make --{without,with}-gallium-drivers work as expected
This version is mostly Dan's post to the mesa-dev mailing list on 6/22/2011. NOTE: This is a candidate for the 7.10 and 7.11 branches. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Dan Nicholson <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a5bb37e6cd..77372735c1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -617,6 +617,13 @@ AC_ARG_WITH([gallium-drivers],
[with_gallium_drivers="$withval"],
[with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT"])
+# Doing '--without-gallium-drivers' will set this variable to 'no'. Clear it
+# here so that the script doesn't choke on an unknown driver name later.
+case "$with_gallium_drivers" in
+ yes) with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT" ;;
+ no) with_gallium_drivers='' ;;
+esac
+
if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xno -a \
"x$enable_gles2" = xno -a \