summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <[email protected]>2008-03-10 14:05:46 -0700
committerDan Nicholson <[email protected]>2008-03-10 16:11:04 -0700
commitb957655a91fe90f477de3e068654f050869c770e (patch)
tree2c75b5b04491d1f301a1466c61c439ddc26e4b18 /configure.ac
parent4dfd2dcbe724dfb6209064b060ea639cba8e17be (diff)
autoconf: Enable xdemos by default when we build libGL
Since the xdemos only link to libGL now, we can enable them for all but the osmesa driver target.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ca3f9171969..b9ad819fe43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -291,7 +291,13 @@ fi
dnl If $with_demos is yes, directories will be added as libs available
PROGRAM_DIRS=""
case "$with_demos" in
-no|yes) ;;
+no) ;;
+yes)
+ # If the driver isn't osmesa, we have libGL and can build xdemos
+ if test "$mesa_driver" != osmesa; then
+ PROGRAM_DIRS="xdemos"
+ fi
+ ;;
*)
# verify the requested demos directories exist
demos=`IFS=,; echo $with_demos`
@@ -644,11 +650,6 @@ if test "x$enable_glu" = xyes; then
fi
;;
*)
- # If GLU is available, we can build the xdemos
- if test "$with_demos" = yes; then
- PROGRAM_DIRS="$PROGRAM_DIRS xdemos"
- fi
-
# If static, empty GLU_LIB_DEPS and add libs for programs to link
if test "$enable_static" = no; then
GLU_LIB_DEPS="-lm"