summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-11 17:08:17 -0700
committerMatt Turner <[email protected]>2012-09-12 11:26:28 -0700
commitaf6aeae4e1286a8858e040602db338de6a1367dc (patch)
tree4acdd80d7a60e78bdb654d9a1b9196bf41b8367a /configure.ac
parent7443e4e697c0517f505d83436dcbe1fd01c1c39e (diff)
build: Don't list glproto and dri2proto in pkg-config file
No files provided by glproto or dri2proto are needed for building something with Mesa. Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=342393 Reviewed-by: Dan Nicholson <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e00bb001404..4193496de95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -861,13 +861,12 @@ xyesyes)
xyesno)
# DRI-based GLX
PKG_CHECK_MODULES([GLPROTO], [glproto >= $GLPROTO_REQUIRED])
- GL_PC_REQ_PRIV="glproto >= $GLPROTO_REQUIRED"
if test x"$driglx_direct" = xyes; then
if test "x$have_libdrm" != xyes; then
AC_MSG_ERROR([Direct rendering requires libdrm >= $LIBDRM_REQUIRED])
fi
PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= $DRI2PROTO_REQUIRED])
- GL_PC_REQ_PRIV="$GL_PC_REQ_PRIV libdrm >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED"
+ GL_PC_REQ_PRIV="$GL_PC_REQ_PRIV libdrm >= $LIBDRM_REQUIRED"
fi
# find the DRI deps for libGL