summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2012-08-10 14:02:03 -0700
committerChad Versace <[email protected]>2012-08-10 14:05:14 -0700
commit996ff1c9bf5c3cd9102367bb3f16341053f87541 (patch)
tree427c0b972067bb4c739b83e4382cc15ed63345db /configure.ac
parent16c702ef3b9cff320c2adbfa853e00088adbf689 (diff)
Revert "mesa: Remove C++11 narrowing warnings"
This reverts commit 9f5a5d541d5c1ff2e440791ba8ff44d0233daeb4. Fixes the following build error on GCC 4.2.3: cc1plus: error: unrecognized command line option "-Wno-narrowing" The GCC Manual incorrectly stated that commit 9f5a5d54 woulde be safe for old versions of GCC. Reported-by: Andy Furniss <[email protected]> Signed-off-by: Chad Versace <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fa4fd712717..89686b47fcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,9 +228,6 @@ if test "x$GXX" = xyes; then
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
CXXFLAGS="$CXXFLAGS -fno-builtin-memcmp"
-
- # Silence C++11 warnings that we don't care about.
- CXXFLAGS="$CXXFLAGS -Wno-narrowing"
fi
dnl even if the compiler appears to support it, using visibility attributes isn't