summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2012-03-05 17:01:13 -0800
committerIan Romanick <[email protected]>2012-04-12 17:18:00 -0700
commit94726d263ebee6364e9be2f254c3ca7d1f85dde4 (patch)
treed1f66e287e2475aef8db5a0210cf9bf3d1d9a532 /configure.ac
parent3d000e7dd14c3185b9e27a6c38a67288b4d10431 (diff)
glx: Hook up the unit tests again using the internal gtest.
Reviewed-by: Ian Romanick <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 9baccab3624..65d358e0a8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,18 +82,6 @@ solaris*)
;;
esac
-AC_PATH_PROG([GTESTCONFIG], [gtest-config])
-if test "x$GTESTCONFIG" != "x"; then
- GTEST_CFLAGS=`gtest-config --cppflags --cxxflags`
- GTEST_LIBS=`gtest-config --ldflags --libs`
- AC_SUBST([GTEST_CFLAGS])
- AC_SUBST([GTEST_LIBS])
- HAVE_GTEST=yes
-else
- HAVE_GTEST=no
-fi
-AM_CONDITIONAL(HAVE_GTEST, test x$HAVE_GTEST = xyes)
-
dnl clang is mostly GCC-compatible, but its version is much lower,
dnl so we have to check for it.
AC_MSG_CHECKING([if compiling with clang])
@@ -794,7 +782,7 @@ dnl
dnl this variable will be prepended to SRC_DIRS and is not exported
CORE_DIRS=""
-SRC_DIRS=""
+SRC_DIRS="gtest"
GLU_DIRS="sgi"
GALLIUM_DIRS="auxiliary drivers state_trackers"
GALLIUM_TARGET_DIRS=""