summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-10-31 18:58:09 +0000
committerEmil Velikov <[email protected]>2017-11-13 17:17:15 +0000
commit7da8440504be1304ba31b51cc3472873941f357f (patch)
treeb1078135d71c7dd60cb72ffec113941b6e67e0c0 /configure.ac
parent797dbe4efa59dbac9a5d4fd950b596ef8cb3f222 (diff)
configure.ac: loosen --enable-glvnd check to honour egl
Currently we error out when building GLVND w/o GLX. That was the original premice before we had EGL. As the commit says, that error should be reworked to honour both - do so. v2: Drop noop *);; (Eric) Reported-by: Lukas Rusak <[email protected]> Fixes: ce562f9e3fa ("EGL: Implement the libglvnd interface for EGL (v3)") Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Tested-by: Lukas Rusak <[email protected]> (v1) (cherry picked from commit b4967561c035182b64d3ae0f474d4ef281535ce1)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index add3830f233..bca5e9ba5d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1383,18 +1383,10 @@ AC_ARG_ENABLE([libglvnd],
AM_CONDITIONAL(USE_LIBGLVND, test "x$enable_libglvnd" = xyes)
if test "x$enable_libglvnd" = xyes ; then
- dnl XXX: update once we can handle more than libGL/glx.
- dnl Namely: we should error out if neither of the glvnd enabled libraries
- dnl are built
case "x$enable_glx" in
- xno)
- AC_MSG_ERROR([cannot build libglvnd without GLX])
- ;;
xxlib | xgallium-xlib )
AC_MSG_ERROR([cannot build libgvnd when Xlib-GLX or Gallium-Xlib-GLX is enabled])
;;
- xdri)
- ;;
esac
PKG_CHECK_MODULES([GLVND], libglvnd >= 0.2.0)
@@ -1403,6 +1395,10 @@ if test "x$enable_libglvnd" = xyes ; then
DEFINES="${DEFINES} -DUSE_LIBGLVND=1"
DEFAULT_GL_LIB_NAME=GLX_mesa
+
+ if test "x$enable_glx" = xno -a "x$enable_egl" = xno; then
+ AC_MSG_ERROR([cannot build libglvnd without GLX or EGL])
+ fi
fi
AC_ARG_WITH([gl-lib-name],