summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-08-02 19:39:04 +0100
committerEmil Velikov <[email protected]>2017-08-04 14:58:50 +0100
commit6f9298dbde63049da6f530ba4f4693ba78b01448 (patch)
treec7a28cdc6a4d4a1bc463d5c14e105c4357482d94 /configure.ac
parentf99a733e3892750402db7b3e9dfb306d3bbff851 (diff)
configure.ac: unconditionally check for expat
Earlier commits moved the xmlconfig library to a wider userbase. Thus having the check within --enable-dri is insufficient. Upon closer look, nine needed it from it's early days - 948e6c52282 ("nine: Add drirc options (v2)") Fixes: 601093f95ddf ("xmlconfig: move into src/util") Cc: Axel Davy <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Nicolai Hähnle <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (IRC)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3b45baf6d08..21092abebf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1791,6 +1791,15 @@ if test "x$with_dri_drivers" = xno; then
with_dri_drivers=''
fi
+# Check for expat
+PKG_CHECK_MODULES([EXPAT], [expat], [],
+ # expat version 2.0 and earlier do not provide expat.pc
+ [AC_CHECK_HEADER([expat.h],[],
+ [AC_MSG_ERROR([Expat headers required for DRI not found])])
+ AC_CHECK_LIB([expat],[XML_ParserCreate],[],
+ [AC_MSG_ERROR([Expat library required for DRI not found])])
+ EXPAT_LIBS="-lexpat"])
+
dnl If $with_dri_drivers is yes, drivers will be added through
dnl platform checks. Set DEFINES and LIB_DEPS
if test "x$enable_dri" = xyes; then
@@ -1824,15 +1833,6 @@ if test "x$enable_dri" = xyes; then
with_dri_drivers="i915 i965 nouveau r200 radeon swrast"
fi
- # Check for expat
- PKG_CHECK_MODULES([EXPAT], [expat], [],
- # expat version 2.0 and earlier do not provide expat.pc
- [AC_CHECK_HEADER([expat.h],[],
- [AC_MSG_ERROR([Expat headers required for DRI not found])])
- AC_CHECK_LIB([expat],[XML_ParserCreate],[],
- [AC_MSG_ERROR([Expat library required for DRI not found])])
- EXPAT_LIBS="-lexpat"])
-
# put all the necessary libs together
DRI_LIB_DEPS="$DRI_LIB_DEPS $SELINUX_LIBS $LIBDRM_LIBS $EXPAT_LIBS -lm $PTHREAD_LIBS $DLOPEN_LIBS"
fi