summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Helland <[email protected]>2017-05-19 22:07:17 +0200
committerThomas Helland <[email protected]>2017-09-26 18:24:46 +0200
commit584a2a22ea40cdc030db5b1d70b23dddcc06a556 (patch)
treeac11f75f34d2d7d754a919faac81e4e84c45cc72 /configure.ac
parent7885bb684d8a1ee9fbdcf85603e1f923a3526b22 (diff)
util: Add tests for the string buffer
More tests could probably be added, but this should cover concatenation, resizing, clearing, formatted printing, and checking the length, so it should be quite complete. Signed-off-by: Thomas Helland <[email protected]> Reviewed-by: Nicolai Hähnle <nicolai.haehnle at amd.com> Tested-by: Dieter Nützel <Dieter at nuetzel-hh.de> V2: Address review feedback from Timothy, plus fixes - Use a large enough char array - Actually test the formatted appending - Test that clear function resets string length V3: Port to gtest V4: Fix test makefile Fix copyright header Fix missing extern C Use more appropriate name for C-file Add tests for append_char
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70e5b088626..cfc97d9f061 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2942,6 +2942,7 @@ AC_CONFIG_FILES([Makefile
src/mesa/state_tracker/tests/Makefile
src/util/Makefile
src/util/tests/hash_table/Makefile
+ src/util/tests/string_buffer/Makefile
src/util/xmlpool/Makefile
src/vulkan/Makefile])