summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-12-08 03:03:38 +0100
committerEmil Velikov <[email protected]>2017-01-18 13:23:01 +0000
commit4d0efb9683856cada2f34b124c77ef20a2fe0332 (patch)
tree0818a39a2c623d60a41dc6c93b45b61e9f51c014 /configure.ac
parentb045d23c0b804074a7fbc849d7098d51056ccb6b (diff)
configure.ac: Set and use HAVE_GALLIUM_LLVM define
Gallium code used HAVE_LLVM to check if it needs to compile code for LLVM in header and source files. With the new logic HAVE_LLVM is always set. Use extra define to figure out if LLVM is used. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=99010 Signed-off-by: Tobias Droste <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c9c316c4e3..5740da6ee91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2573,6 +2573,7 @@ if test "x$enable_gallium_llvm" == "xyes"; then
llvm_add_default_components "gallium"
HAVE_GALLIUM_LLVM=yes
+ DEFINES="${DEFINES} -DHAVE_GALLIUM_LLVM"
fi
dnl We need to validate some needed dependencies for renderonly drivers.