summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-13 10:45:01 -0700
committerAndreas Boll <[email protected]>2013-01-10 22:01:30 +0100
commit45270fb0fd1abd7619933c2845f9dc74cdfbe6fd (patch)
treeb7765f6f7b5df3fc43fc9354d1b245be76f61a78 /configure.ac
parent53c62d3fb0ee9aacc7a4aa08b4c42a3fb2127b2f (diff)
targets/pipe-loader: Convert to automake
C++ linking (controlled by the nodist_EXTRA idiom) is needed unconditionally for: nouveau (uses C++ in the driver) r300 (since LLVM is always required) radeonsi (since LLVM is always required) swrast (if builting LLVM pipe) and conditionally (depends whether LLVM is enabled) for i915 r600 vmwgfx and never needed for swrast (softpipe). Unfortunately, automake seems to *always* link with C++ if nodist_EXTRA is specified, even inside a false conditional. Not sure if this is a bug, but it does seem to be weird behavior. v2: Johannes Obermayr <[email protected]> - Fix some undefined symbols. v3: Johannes Obermayr <[email protected]> - Install pipe_* to $(libdir)/gallium-pipe. v4: Johannes Obermayr <[email protected]> - Build it only once on --enable-gallium-gbm / --enable-opencl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3c328b64ae3..59226545526 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1493,6 +1493,10 @@ if test "x$enable_opencl" = xyes; then
enable_gallium_loader=yes
fi
+if test "x$enable_gallium_gbm" = xyes || test "x$enable_opencl" = xyes; then
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS pipe-loader"
+fi
+
dnl
dnl Gallium configuration
dnl
@@ -2078,6 +2082,7 @@ AC_CONFIG_FILES([configs/current
src/gallium/targets/egl-static/Makefile
src/gallium/targets/gbm/Makefile
src/gallium/targets/opencl/Makefile
+ src/gallium/targets/pipe-loader/Makefile
src/gallium/targets/libgl-xlib/Makefile
src/gallium/targets/vdpau-nouveau/Makefile
src/gallium/targets/vdpau-r300/Makefile