summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2013-11-05 13:53:45 -0800
committerMatt Turner <[email protected]>2013-11-07 10:00:25 -0800
commitd8abd6710ea41545ae2fb9b8e718d29a69574b1a (patch)
tree6d001f0f881458b6dc129c17909a6af9f27f1ae0 /configure.ac
parent957c7570ea3f7d6ea4cf2cc49d85207136fb0470 (diff)
build: Change HAVE_X86_ASM to mean x86 or x86-64 asm.
I want a conditional that says generally "we have x86 assembly" in the next patch. Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65905831fab..0896d857a59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1938,7 +1938,7 @@ AM_CONDITIONAL(HAVE_X11_DRIVER, test "x$enable_xlib_glx" = xyes)
AM_CONDITIONAL(HAVE_OSMESA, test "x$enable_osmesa" = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_OSMESA, test "x$enable_gallium_osmesa" = xyes)
-AM_CONDITIONAL(HAVE_X86_ASM, test "x$asm_arch" = xx86)
+AM_CONDITIONAL(HAVE_X86_ASM, test "x$asm_arch" = xx86 -o "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_X86_64_ASM, test "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_SPARC_ASM, test "x$asm_arch" = xsparc)