summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-02-24 22:58:10 +0000
committerEmil Velikov <[email protected]>2014-02-28 22:47:56 +0000
commite283e966660fdf037be6353dc96b7f63b8aa315a (patch)
tree0c868240ba7d554a4f611c374da1d18bcc4aedd1 /configure.ac
parent2e830bba214656c84720669667b36eba7449fe13 (diff)
configure: error out when building xa only with swrast
Building to provide accelration using swrast does not make sense. Note: update your build script to explicitly mention svga in the gallium drivers list, if you are building the vmwgfx xa library. v2: Update error message to provide more clarify, add an example. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c24a59a57a..75182ee730e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1239,6 +1239,14 @@ dnl
dnl XA configuration
dnl
if test "x$enable_xa" = xyes; then
+ if test "x$with_gallium_drivers" = xswrast; then
+ AC_MSG_ERROR([
+ Building xa requires at least one non swrast gallium driver.
+ If you are looking to use libxatracker.so with vmware's virtual gpu,
+ make sure to include svga in the gallium drivers list, apart from
+ enabling XA.
+ Example: ./configure --enable-xa --with-gallium-drivers=svga...])
+ fi
GALLIUM_STATE_TRACKERS_DIRS="xa $GALLIUM_STATE_TRACKERS_DIRS"
enable_gallium_loader=yes
enable_gallium_drm_loader=yes