summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-06-10 17:46:24 +0100
committerEmil Velikov <[email protected]>2016-06-13 15:24:44 +0100
commitbab5ab69402594637359289c1b5ec6491e91d252 (patch)
tree5239b02c1b0a3f27feaa92647e1835afa7d38882 /configure.ac
parentc86fcaca72ed500eac63d5633e0d7ffb77de9acf (diff)
configure.ac: strip out the llvm-config -march/mtune flags
Otherwise drivers such as SWR that depend on providing their own values will fail to build. v2: Add -mcpu for good measure (Chuck) Cc: "11.2 12.0" <[email protected]> Cc: Tim Rowley <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Chuck Atkins <[email protected]> Tested-by: Chuck Atkins <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33d1fefc543..c492e158f76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2102,6 +2102,9 @@ AC_ARG_WITH([llvm-prefix],
strip_unwanted_llvm_flags() {
# Use \> (marks the end of the word)
echo `$1` | sed \
+ -e 's/-march=\S*//g' \
+ -e 's/-mtune=\S*//g' \
+ -e 's/-mcpu=\S*//g' \
-e 's/-DNDEBUG\>//g' \
-e 's/-D_GNU_SOURCE\>//g' \
-e 's/-pedantic\>//g' \