summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2014-06-02 17:40:38 +0100
committerJon TURNEY <[email protected]>2014-07-08 14:25:21 +0100
commit7a641dd58ddfba2b7e9483278c05ba752864213d (patch)
tree520c580edc78af4aa9e590251f6362dad6e961b3 /configure.ac
parent8ff16111eee309652b5409890c42d042e33770e2 (diff)
configure: Don't special case Cygwin to use gnu99, define _XOPEN_SOURCE instead
Revert "build: Build on Cygwin with gnu99 instead of c99." and define _XOPEN_SOURCE appropriately. This reverts commit 53e36d333c9b619c1a5fe9a8d2d08665654b0234. Since Cygwin 1.7.18 (April 2013), it's headers correctly prototype strtoll() when using -std=c99, and correctly prototype strdup() when _XOPEN_SOURCE is defined appropriately, so this workaround is no longer needed. Signed-off-by: Jon TURNEY <[email protected]> Cc: Vinson Lee <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4646212be8a..701223b5980 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,20 +159,13 @@ solaris*)
DEFINES="$DEFINES -DHAVE_PTHREAD -DSVR4"
;;
cygwin*)
- DEFINES="$DEFINES -DHAVE_PTHREAD"
+ DEFINES="$DEFINES -D_XOPEN_SOURCE=500 -DHAVE_PTHREAD"
;;
esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- case "$host_os" in
- cygwin*)
- CFLAGS="$CFLAGS -Wall -std=gnu99"
- ;;
- *)
- CFLAGS="$CFLAGS -Wall -std=c99"
- ;;
- esac
+ CFLAGS="$CFLAGS -Wall -std=c99"
# Enable -Werror=implicit-function-declaration and
# -Werror=missing-prototypes, if available, or otherwise, just