summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Demers <[email protected]>2013-11-22 20:06:20 -0500
committerEmil Velikov <[email protected]>2014-08-12 23:36:06 +0100
commit2af28040d639dddbb7c258981a00eaf3dfcbcf03 (patch)
tree57fc60bf9a42c367ec9199fb8dc713f4d0986154 /configure.ac
parent469416f988bcd471fb6058cdfb5ffebe840545da (diff)
configure: Fix --enable-XX-bit flags by moving LT_INIT where it should
Moving LT_INIT after setting completely (AM_)C(XX)FLAGS and LDFLAGS. LT_INIT needs them as they are expected to be used all along the compilation when the macro runs its tests to determine among other things the host type. For info, see http://www.gnu.org/software/libtool/manual/html_node/LT_005fINIT.html Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=50754 Signed-off-by: Alexandre Demers <[email protected]> Tested-by: Tapani Palli <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cd02babd673..b27cfb3f41b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,9 +57,6 @@ AC_CHECK_PROGS([PYTHON2], [python2 python])
AC_PROG_SED
AC_PROG_MKDIR_P
-LT_PREREQ([2.2])
-LT_INIT([disable-static])
-
AX_PROG_BISON([],
AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"],
[AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))
@@ -2190,6 +2187,14 @@ dnl Add user CFLAGS and CXXFLAGS
CFLAGS="$CFLAGS $USER_CFLAGS"
CXXFLAGS="$CXXFLAGS $USER_CXXFLAGS"
+dnl
+dnl LT_INIT adds tests to determine host based on some variables like (AM_)C(XX)FLAGS and (AM_)LDFLAGS.
+dnl They need to be set before calling LT_INIT so the macro can configure things correctly when cross_compiling.
+dnl This will allow --enable-xx-bit to work as expected.
+dnl
+LT_PREREQ([2.2])
+LT_INIT([disable-static])
+
dnl Substitute the config
AC_CONFIG_FILES([Makefile
src/Makefile