summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2016-10-18 23:47:01 +0200
committerMarek Olšák <[email protected]>2016-10-26 13:02:58 +0200
commit1ac40173c2abf402150ffa245d03664b159e89e0 (patch)
tree6deba532480c14d3b2061b97afa57eeba877ed6d /configure.ac
parentb687f766fddb7b39479cd9ee0427984029ea3559 (diff)
configure.ac: simplify EGL requirements for drivers dependent on EGL
Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 13 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 30817d867f9..4761c5972e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2296,22 +2296,21 @@ gallium_require_llvm() {
fi
}
-dnl This is for Glamor. Skip this if OpenGL is disabled.
-require_egl_drm() {
- if test "x$enable_opengl" = xno; then
- return 0
- fi
-
+dnl
+dnl DRM is needed by X, Wayland, and offscreen rendering.
+dnl Surfaceless is an alternative for the last one.
+dnl
+require_basic_egl() {
case "$with_egl_platforms" in
- *drm*)
+ *drm*|*surfaceless*)
;;
- *)
- AC_MSG_ERROR([--with-egl-platforms=drm is required to build the $1 driver.])
+ *)
+ AC_MSG_ERROR([$1 requires one of these:
+ 1) --with-egl-platforms=drm (X, Wayland, offscreen rendering based on DRM)
+ 2) --with-egl-platforms=surfaceless (offscreen only)
+ Recommended options: drm,x11])
;;
esac
- if test "x$enable_gbm" != xyes; then
- AC_MSG_ERROR([--enable-gbm is required to build the $1 driver.])
- fi
}
radeon_llvm_check() {
@@ -2427,7 +2426,7 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([AMDGPU], [libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
require_libdrm "radeonsi"
radeon_gallium_llvm_check "radeonsi" "3" "6" "0"
- require_egl_drm "radeonsi"
+ require_basic_egl "radeonsi"
;;
xnouveau)
HAVE_GALLIUM_NOUVEAU=yes
@@ -2478,7 +2477,7 @@ if test -n "$with_gallium_drivers"; then
xvirgl)
HAVE_GALLIUM_VIRGL=yes
require_libdrm "virgl"
- require_egl_drm "virgl"
+ require_basic_egl "virgl"
;;
*)
AC_MSG_ERROR([Unknown Gallium driver: $driver])