summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-09-01 11:51:49 +0100
committerEmil Velikov <[email protected]>2017-09-19 19:02:34 +0100
commitfa6b9be22c7a85a8766a31411caafdbe1694d7dc (patch)
tree197501ccaa38f8d4f52c113c5f84d8d958304ee6 /configure.ac
parentbe52bd17ebf114e7ad16a6d9d0135cdbb0723cd0 (diff)
configure.ac: define WL_HIDE_DEPRECATED at global scale
Due to GCC feature described in previous commit, the expected deprecation warnings may be missing. Set the WL_HIDE_DEPRECATED macro which will omit the deprecated functionality, resulting in more distinct build issues. That is safe since the symbols guarded within the macro is static. Signed-off-by: Emil Velikov <[email protected]> Suggested-by: Pekka Paalanen <[email protected]> Acked-by: Pekka Paalanen <[email protected]> Reviewed-by: Daniel Stone <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 605c9b4e992..5fa608c4dd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1718,7 +1718,7 @@ for plat in $platforms; do
if test "x$have_wayland_protocols" = xno; then
AC_MSG_ERROR([wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED is needed to compile the wayland platform])
fi
- DEFINES="$DEFINES -DHAVE_WAYLAND_PLATFORM"
+ DEFINES="$DEFINES -DHAVE_WAYLAND_PLATFORM -DWL_HIDE_DEPRECATED"
;;
x11)