summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-12-07 13:25:01 +0000
committerEmil Velikov <[email protected]>2017-01-18 16:01:15 +0000
commit687cf37bbe724d3bd910d5d8c55eb27e1b196f65 (patch)
tree88e89c3fc28100029575531868c215423362bf98 /configure.ac
parentda410e6afad30126fde993782f60404bd976cbc9 (diff)
configure: error out when building static XOR shared
Current code warns out in such cases and falls-back to either static or shared. That can be easily missed amongst the volume produced by our configure script. Replace the warning with an error such that one gets direct feedback when they're doing something wrong. Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6771aa64e16..33f1c42c8be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -468,12 +468,10 @@ dnl explicitly requested. If both disabled, set to static since shared
dnl was explicitly requested.
case "x$enable_static$enable_shared" in
xyesyes)
- AC_MSG_WARN([Cannot build static and shared libraries, disabling shared])
- enable_shared=no
+ AC_MSG_ERROR([Cannot enable both static and shared. Building using --enable-shared is strongly recommended])
;;
xnono)
- AC_MSG_WARN([Cannot disable both static and shared libraries, enabling shared])
- enable_shared=yes
+ AC_MSG_ERROR([Cannot disable both static and shared. Building using --enable-shared is strongly recommended])
;;
esac