summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-08-02 19:39:05 +0100
committerEmil Velikov <[email protected]>2017-08-04 14:58:50 +0100
commit5c007203b73da88b9e76ce28027c6d27661e45b1 (patch)
treec7ed05c4c34e02f33e3ae2722cccd31beebd5bea /configure.ac
parent6f9298dbde63049da6f530ba4f4693ba78b01448 (diff)
configure.ac: drop manual detection of expat header/library
Use the .pc file, as provided by version prior 2.1.0 onward and dropping the manual header/library check. Version 2.1.0 was released back in Mar 2012 and all major distributions use it. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Nicolai Hähnle <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (IRC)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 21092abebf7..5b12dd8506a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1792,13 +1792,7 @@ if test "x$with_dri_drivers" = xno; then
fi
# Check for expat
-PKG_CHECK_MODULES([EXPAT], [expat], [],
- # expat version 2.0 and earlier do not provide expat.pc
- [AC_CHECK_HEADER([expat.h],[],
- [AC_MSG_ERROR([Expat headers required for DRI not found])])
- AC_CHECK_LIB([expat],[XML_ParserCreate],[],
- [AC_MSG_ERROR([Expat library required for DRI not found])])
- EXPAT_LIBS="-lexpat"])
+PKG_CHECK_MODULES([EXPAT], [expat])
dnl If $with_dri_drivers is yes, drivers will be added through
dnl platform checks. Set DEFINES and LIB_DEPS