summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-04-25 16:39:52 +0100
committerEmil Velikov <[email protected]>2017-05-19 19:44:06 +0100
commit2d35773221d63658bb764f90bd7be95f910f6309 (patch)
treeb757868e78e3192575a112dc916bfc2cda17b566 /configure.ac
parentedb5a65f93189472814afa97b1e3a54b2478b543 (diff)
configure: enable the surfaceless platform by default
A simple platform that you want to use in a many usecases. See the spec file details. It has no special requirements plus it takes less than a second to build. Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Acked-by: Tapani Pälli <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index de422107a26..f741efcb7c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1643,10 +1643,9 @@ AC_ARG_WITH([egl-platforms],
[with_egl_platforms=auto])
if test "x$with_egl_platforms" = xauto; then
+ with_egl_platforms="x11,surfaceless"
if test "x$enable_gbm" = xyes; then
- with_egl_platforms="x11,drm"
- else
- with_egl_platforms="x11"
+ with_egl_platforms="$with_egl_platforms,drm"
fi
else
AC_MSG_WARN([--with-egl-platforms is deprecated. Use --with-platforms instead.])