summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-07-17 14:16:58 +0000
committerTom Stellard <[email protected]>2012-07-17 12:08:24 -0400
commited41a559dc3293dab75c4f0198531a6f5b870c39 (patch)
tree610d6de2bdaab3648a45086021c48ce25a7cee1b /configure.ac
parentfadc9eaf97c0916d5680c1d3b47e80532ede22c1 (diff)
configure.ac: Add libLLVMMCJIT to the LLVM_LDFLAGS
This is neccessary for linking the llvmpipe tests. It appears this dependency was introduced by the "wider native register" changes. Reviewed-by: Jose Fonseca <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9227474f13f..068f632d308 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1849,7 +1849,7 @@ if test "x$enable_gallium_llvm" = xyes; then
else
LLVM_LIBS="`$LLVM_CONFIG --libs engine bitwriter`"
if test "x$enable_opencl" = xyes; then
- LLVM_LIBS="${LLVM_LIBS} `llvm-config --libs ipo linker instrumentation`"
+ LLVM_LIBS="${LLVM_LIBS} `llvm-config --libs ipo linker instrumentation mcjit`"
fi
fi
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`