summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <[email protected]>2016-04-23 17:39:02 +1000
committerKenneth Graunke <[email protected]>2016-04-23 01:06:20 -0700
commite29b3bfd6e5200aebbff6f056c49e978682ccc09 (patch)
tree660147a630da2a69eaa2bd9bad3ffb1e07e0d0e5 /configure.ac
parentf8dd07a2c3db3f023212289845e7d97cf3527df1 (diff)
configure.ac: search for and set PYTHON3
src/intel/genxml/gen_pack_header.py requires python3. v2: check for python3.5 as well Signed-off-by: Jonathan Gray <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4ce8fe1ad6..38d1f5baf89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,7 @@ AM_PROG_CC_C_O
AM_PROG_AS
AX_CHECK_GNU_MAKE
AC_CHECK_PROGS([PYTHON2], [python2.7 python2 python])
+AC_CHECK_PROGS([PYTHON3], [python3.5 python3.4 python3])
AC_PROG_SED
AC_PROG_MKDIR_P
@@ -2779,6 +2780,7 @@ if test "x$MESA_LLVM" = x1; then
echo ""
fi
echo " PYTHON2: $PYTHON2"
+echo " PYTHON3: $PYTHON3"
echo ""
echo " Run '${MAKE-make}' to build Mesa"