summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaarten Lankhorst <[email protected]>2011-10-18 14:24:30 +0200
committerChristoph Bumiller <[email protected]>2011-10-21 23:39:01 +0200
commitdf8f864bf6fb8dfd256455a5310ef70f820a5350 (patch)
tree4998b64d217f63afc3585a5feed64af87f96782e /configure.ac
parent27b0c9d51300712f3b5d4af6cc20d53fcf9c8c46 (diff)
gallium/targets: Add vdpau target for nouveau
Should fall back to shader based decoding (g3dvl) for now. This is probably broken on systems that support xvmc, because nouveau_video_buffer_create has no way to know for what api the buffer is created, so I think this call might need a separate argument as workaround. Signed-off-by: Maarten Lankhorst <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0864b55af0e..36961452866 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1858,7 +1858,7 @@ if test "x$with_gallium_drivers" != x; then
xnouveau)
PKG_CHECK_MODULES([NOUVEAU], [libdrm_nouveau >= $LIBDRM_NOUVEAU_REQUIRED])
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nvfx nv50 nvc0"
- gallium_check_st "nouveau/drm" "dri-nouveau" "xorg-nouveau" "" "xvmc-nouveau"
+ gallium_check_st "nouveau/drm" "dri-nouveau" "xorg-nouveau" "" "xvmc-nouveau" "vdpau-nouveau"
;;
xswrast)
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS softpipe"