summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2014-04-24 13:40:56 +0200
committerMarek Olšák <[email protected]>2014-05-06 16:59:35 +0200
commitcc71df56521f10571fe8c75761a330d4eade0349 (patch)
treef2b1c57194b2fbf8383ce3fc08e9144a1fb4822d /configure.ac
parente65917f94e5fd13eb75f874fac4d77a29737e808 (diff)
configure.ac: radeonsi requires EGL_DRM and GBM
Reviewed-by: Michel Dänzer <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e77ed778c36..d6f21ea8760 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1744,6 +1744,19 @@ gallium_require_drm_loader() {
fi
}
+require_egl_drm() {
+ case "$with_egl_platforms" in
+ *drm*)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-egl-platforms=drm is required to build the $1 driver.])
+ ;;
+ esac
+ if test "x$enable_gbm" != xyes; then
+ AC_MSG_ERROR([--enable-gbm is required to build the $1 driver.])
+ fi
+}
+
radeon_llvm_check() {
if test "x$enable_gallium_llvm" != "xyes"; then
AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
@@ -1835,6 +1848,7 @@ if test -n "$with_gallium_drivers"; then
gallium_require_drm_loader
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS radeonsi"
radeon_llvm_check "radeonsi"
+ require_egl_drm "radeonsi"
gallium_check_st "radeon/drm" "radeonsi/dri" "" "" "radeonsi/vdpau" "radeonsi/omx"
DRICOMMON_NEED_LIBDRM=yes
;;