summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-02-03 20:38:10 +0000
committerEmil Velikov <[email protected]>2014-02-17 23:59:25 +0000
commit49e93e89455c4ef3d048cc2b3f126be47ff2b55f (patch)
tree20e9972ac6a73c6bc08050eda9dfe68b8e518726 /configure.ac
parentd23f9e3390e8ec19efe3b76818d2bb6bf4264764 (diff)
configure: cleanup switch statement
Move all the cases within one switch statement and handle i9{1,6}5 and r{adeon,200} independently. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 12 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index e1d4806938f..9c070800c11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1076,49 +1076,26 @@ AC_SUBST([DRI_LIB_DEPS])
AC_SUBST([GALLIUM_DRI_LIB_DEPS])
case $DRI_DIRS in
-*i915*|*i965*)
+*i915*)
PKG_CHECK_MODULES([INTEL], [libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
-
- for d in $(echo $DRI_DIRS | sed 's/,/ /g'); do
- case $d in
- i915)
- HAVE_I915_DRI=yes;
- ;;
- i965)
- HAVE_I965_DRI=yes;
- ;;
- esac
- done
-
+ HAVE_I915_DRI=yes;
+ ;;
+*i965*)
+ PKG_CHECK_MODULES([INTEL], [libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
+ HAVE_I965_DRI=yes;
;;
-esac
-
-case $DRI_DIRS in
*nouveau*)
PKG_CHECK_MODULES([NOUVEAU], [libdrm_nouveau >= $LIBDRM_NVVIEUX_REQUIRED])
HAVE_NOUVEAU_DRI=yes;
;;
-esac
-
-case $DRI_DIRS in
-*radeon*|*r200*)
+*radeon*)
PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
-
- for d in $(echo $DRI_DIRS | sed 's/,/ /g'); do
- case $d in
- radeon)
- HAVE_RADEON_DRI=yes;
- ;;
- r200)
- HAVE_R200_DRI=yes;
- ;;
- esac
- done
-
+ HAVE_RADEON_DRI=yes;
+ ;;
+*r200*)
+ PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
+ HAVE_R200_DRI=yes;
;;
-esac
-
-case $DRI_DIRS in
*swrast*)
HAVE_SWRAST_DRI=yes;
;;