summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <[email protected]>2016-11-19 02:38:55 +0100
committerEmil Velikov <[email protected]>2016-12-05 14:43:46 +0000
commitd434633b76108f0e1e456fc91e8eed8df51553e8 (patch)
tree0fb9e352c11f706d5335e942e04193cefc117f69 /configure.ac
parent352831c5d9fcef43804ed2153d509b2d43cf44e9 (diff)
configure.ac: Use new llvm_add_default_components
Signed-off-by: Tobias Droste <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 08f511c443e..82b9e5ff790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2242,11 +2242,7 @@ if test "x$enable_gallium_llvm" = xyes || test "x$HAVE_RADEON_VULKAN" = xyes; th
AC_MSG_ERROR([LLVM $LLVM_REQUIRED_VERSION_MAJOR.$LLVM_REQUIRED_VERSION_MINOR or newer is required])
fi
- LLVM_COMPONENTS="engine bitwriter mcjit mcdisassembler"
-
- if $LLVM_CONFIG --components | grep -q inteljitevents ; then
- LLVM_COMPONENTS="${LLVM_COMPONENTS} inteljitevents"
- fi
+ llvm_add_default_components "gallium"
if test "x$enable_opencl" = xyes; then
llvm_check_version_for "3" "6" "0" "opencl"