summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-06-12 16:38:54 +0100
committerEmil Velikov <[email protected]>2014-06-26 14:05:13 +0100
commitd23497c256539d4a49120cfeeb043c9f2ef8e09b (patch)
treee466e616d3b0b42ed47fd59f810324d24d102083 /configure.ac
parentb1f4a9681fba954bb7f3e8c4877e7ad62703cb0b (diff)
targets/r600/omx: convert to static/shared pipe-drivers
The r600 counterpart of previous commit - now the libomx-r600 is built into the libomx-mesa library. Providing a single library per API. v2: Include the radeon winsys only when there is a user for it. v3: Correcly include the winsys. Now with extra brown bag :\ Note: Make sure to rebuild the .omxregister file, by executing $ omxregister-bellagio If you have more than one omx library (libomx-radeonsi, libomx-r600), make sure to temporary move the unused one. By the end of the series there will be only one library that will be used for all hardware - r600, radeonsi and nouveau. Cc: Leo Liu <[email protected]> Cc: Christian König <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Christian König <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51a0b4fd3d1..7d13e3f6c40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1952,7 +1952,7 @@ if test -n "$with_gallium_drivers"; then
if test "x$enable_opencl" = xyes; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} bitreader asmparser"
fi
- gallium_check_st "radeon/drm" "r600/dri" "" "xvmc/r600" "vdpau/r600" "r600/omx"
+ gallium_check_st "radeon/drm" "r600/dri" "" "xvmc/r600" "vdpau/r600" "omx/r600"
DRICOMMON_NEED_LIBDRM=yes
;;
xradeonsi)
@@ -2222,7 +2222,6 @@ AC_CONFIG_FILES([Makefile
src/gallium/targets/pipe-loader/Makefile
src/gallium/targets/r300/dri/Makefile
src/gallium/targets/r600/dri/Makefile
- src/gallium/targets/r600/omx/Makefile
src/gallium/targets/radeonsi/dri/Makefile
src/gallium/targets/radeonsi/omx/Makefile
src/gallium/targets/vdpau/Makefile