summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2013-10-23 15:36:41 -0400
committerTom Stellard <[email protected]>2013-11-11 17:21:35 -0500
commitcb080a10b68b82467ebb6f62e047f15cd2e5af80 (patch)
tree9007d15c82f18ca178fe1c0320f5571a7de4488e /configure.ac
parent6d6c749215739d0b5f5143dd00a782082b3d03a2 (diff)
configure.ac: Don't require shared LLVM when building OpenCL
This works now that pipe_*.so is no longer exporting LLVM symbols. Tested-by: Kai Wasserbäch <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f756b736112..e4a72849046 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1524,12 +1524,6 @@ AC_ARG_WITH([llvm-shared-libs],
[link with LLVM shared libraries @<:@default=disabled@:>@])],
[],
[with_llvm_shared_libs=no])
-AS_IF([test x$enable_opencl = xyes],
- [
- if test "x$with_llvm_shared_libs" != xyes; then
- AC_MSG_ERROR([OpenCL requires LLVM shared libraries])
- fi
- ])
AC_ARG_WITH([llvm-prefix],
[AS_HELP_STRING([--with-llvm-prefix],