summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2011-04-29 12:52:10 +0100
committerMarek Olšák <[email protected]>2011-05-02 17:34:42 +0200
commit9cb800a97c0ddf87f7870b2a025ab5b8785a426d (patch)
treeaf7aa81a5c683140b022010d9fa777a26e4abdfe /configure.ac
parent02b352e2ace126e880d7df6a8c669e181b76e05f (diff)
Default to --disable-gallium-r300 if not --with-driver=dri
Signed-off-by: Jon TURNEY <[email protected]> Signed-off-by: Marek Olšák <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b05ca35380..54d9c296862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1784,6 +1784,13 @@ AC_ARG_ENABLE([gallium-r300],
[build gallium r300 @<:@default=build DRI driver only@:>@])],
[enable_gallium_r300="$enableval"],
[enable_gallium_r300=auto])
+
+if test "$mesa_driver" != dri ; then
+ if test "x$enable_gallium_r300" = xauto; then
+ enable_gallium_r300=no
+ fi
+fi
+
if test "x$enable_gallium_r300" != xno; then
if test "x$MESA_LLVM" = x0; then
case "$host_cpu" in