summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-09-20 15:08:02 -0700
committerMatt Turner <[email protected]>2012-10-01 15:23:05 -0700
commit523c01524638b3d1bb363f4c0a647b0777840b7a (patch)
tree4d6b56383239919045adbd38f029a88dcbedfa21 /configure.ac
parentb6c0fa1280c523eb5c75d5508cd18d5ae7c8b21c (diff)
build: Don't build libdricore if not building classic drivers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f96cffcfcb4..3dcb1e0ac65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1102,6 +1102,7 @@ if test "x$enable_dri" = xyes; then
DRI_LIB_DEPS="$DRI_LIB_DEPS $SELINUX_LIBS $LIBDRM_LIBS $EXPAT_LIB -lm $PTHREAD_LIBS $DLOPEN_LIBS"
GALLIUM_DRI_LIB_DEPS="$GALLIUM_DRI_LIB_DEPS $SELINUX_LIBS $LIBDRM_LIBS $EXPAT_LIB -lm $PTHREAD_LIBS $DLOPEN_LIBS"
fi
+AM_CONDITIONAL(NEED_LIBDRICORE, test -n "$DRI_DIRS")
AC_SUBST([DRI_DIRS])
AC_SUBST([EXPAT_INCLUDES])
AC_SUBST([DRI_LIB_DEPS])