summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Fonseca <[email protected]>2015-12-01 22:43:46 +0000
committerJose Fonseca <[email protected]>2015-12-02 07:51:04 +0000
commit51564f04b77e6d29a888a4fbd83d96de062ac634 (patch)
treeb84ebbeed13ca3e33f6351871a224557975a517a /configure.ac
parent18f8da7865ddc27e4bb17f935c826f803bdfd5ba (diff)
configure.ac: Refuse to build with Sun C compiler.
https://bugs.freedesktop.org/show_bug.cgi?id=93189 Reviewed-by: Matt Turner <[email protected]> Tested-by: Vinson Lee <[email protected]> Acked-by: Alan Coopersmith <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40168715fc6..b6680d04fd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,13 @@ if test "x$GCC" = xyes -a "x$acv_mesa_CLANG" = xno; then
fi
fi
+dnl We don't support building Mesa with Sun C compiler
+dnl https://bugs.freedesktop.org/show_bug.cgi?id=93189
+AC_CHECK_DECL([__SUNPRO_C], [SUNCC=yes], [SUNCC=no])
+if test "x$SUNCC" = xyes; then
+ AC_MSG_ERROR([Building with Sun C compiler is not supported, use GCC instead.])
+fi
+
dnl Check for compiler builtins
AX_GCC_BUILTIN([__builtin_bswap32])
AX_GCC_BUILTIN([__builtin_bswap64])