summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2011-10-14 14:33:00 -0700
committerEric Anholt <[email protected]>2011-10-28 11:31:11 -0700
commit48c9925367034b6fac506f1f32d445c5bd825a49 (patch)
tree6594761527aec2a3872ba5b24401a2383c0240e8 /configure.ac
parentbd51e8e4f473dd4fb4f99ed7898d771c64caca2d (diff)
configure.ac: Fix equality checks in gallium st setup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 11d81bca28a..ab3ba25e937 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1878,9 +1878,9 @@ if test "x$with_gallium_drivers" != x; then
if test "x$HAVE_ST_VA" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS va-softpipe"
fi
- if test "x$HAVE_ST_VDPAU" == xyes ||
- test "x$HAVE_ST_XVMC" == xyes ||
- test "x$HAVE_ST_VA" == xyes; then
+ if test "x$HAVE_ST_VDPAU" = xyes ||
+ test "x$HAVE_ST_XVMC" = xyes ||
+ test "x$HAVE_ST_VA" = xyes; then
if test "x$HAVE_WINSYS_XLIB" != xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
fi