summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-02-23 19:32:08 +0000
committerEmil Velikov <[email protected]>2018-08-08 13:37:09 +0100
commit315c46cfdc3dbd4d51b74ab26df693725e947724 (patch)
treeda4d9adfa55a45b08cfd271a0503e300e68f2d1b /configure.ac
parent8dc96416c912eda51039f2146aad40dc10da2516 (diff)
autotools: use correct gl.pc LIBS when using glvnd
This is more of a hack, since glvnd itself should be providing the file. Until that happens, ensure the libs is correctly set to -lGL CC: <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Adam Jackson <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2c48a455c2..c2155a541b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1534,6 +1534,15 @@ fi
AC_SUBST([GL_LIB])
AC_SUBST([OSMESA_LIB])
+dnl HACK when building glx + glvnd we ship gl.pc, despite that glvnd should do it
+dnl Thus we need to use GL as a DSO name.
+if test "x$enable_libglvnd" = xyes -a "x$enable_glx" != xno; then
+ GL_PKGCONF_LIB="GL"
+else
+ GL_PKGCONF_LIB="$GL_LIB"
+fi
+AC_SUBST([GL_PKGCONF_LIB])
+
# Check for libdrm
PKG_CHECK_MODULES([LIBDRM], [libdrm >= $LIBDRM_REQUIRED],
[have_libdrm=yes], [have_libdrm=no])