summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLaurent Carlier <[email protected]>2012-06-24 09:51:27 +0200
committerJon TURNEY <[email protected]>2012-07-13 12:43:39 +0100
commit284325d97b3049e59e64daf784e2b3858f0ffcf5 (patch)
tree1cda662cc612d8faef3d1b227485ab7d40090faa /configure.ac
parent1a06e8454ec714e950bc88882cd985534a18bf1f (diff)
automake: convert libOSmesa
This also currently fix the installation of libOSmesa. v2: Remove old Makefile, libOSmesa is now versioned, fix typos v3: Keep config substitution alphabetized v4: Update .gitignore v5: Libraries will be in the builddir, not the srcdir. Reviewed-by: Jon TURNEY <[email protected]> Reviewed-by: Eric Anholt <[email protected]> Tested-by: Matt Turner <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08ea5beb400..5390868a7da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1351,10 +1351,14 @@ if test "x$enable_osmesa" = xyes; then
OSMESA_MESA_DEPS=""
OSMESA_PC_LIB_PRIV="-lm -lpthread $SELINUX_LIBS $DLOPEN_LIBS"
fi
+
+OSMESA_VERSION=`echo "$VERSION" | $SED 's/\./:/g'`
+
AC_SUBST([OSMESA_LIB_DEPS])
AC_SUBST([OSMESA_MESA_DEPS])
AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
+AC_SUBST([OSMESA_VERSION])
dnl
dnl gbm configuration
@@ -2169,6 +2173,7 @@ AC_CONFIG_FILES([configs/current
src/mesa/drivers/dri/r200/Makefile
src/mesa/drivers/dri/radeon/Makefile
src/mesa/drivers/dri/swrast/Makefile
+ src/mesa/drivers/osmesa/Makefile
src/mesa/drivers/x11/Makefile
src/mesa/gl.pc
src/mesa/osmesa.pc])