summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-05-03 21:24:26 +0100
committerJuan A. Suarez Romero <[email protected]>2017-05-31 22:32:02 +0200
commit1d89787a1971e0e3cd68a2401b047da080d1a1c9 (patch)
treed27cea2be5b00f1ecb89e704e594b57cb6c6da64 /configure.ac
parent29dc0b2d8c89ae0f49ad13440e9d217cbf06c477 (diff)
configure: loosen --with-platforms heuristics
Remove the enable-egl pre-requirement. Platform selection does not depend on EGL. Cc: <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (cherry picked from commit edb5a65f93189472814afa97b1e3a54b2478b543) Signed-off-by: Juan A. Suarez Romero <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6b2d9f152bd..cbba0f60233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1643,14 +1643,10 @@ AC_ARG_WITH([egl-platforms],
[with_egl_platforms=auto])
if test "x$with_egl_platforms" = xauto; then
- if test "x$enable_egl" = xyes; then
- if test "x$enable_gbm" = xyes; then
- with_egl_platforms="x11,drm"
- else
- with_egl_platforms="x11"
- fi
+ if test "x$enable_gbm" = xyes; then
+ with_egl_platforms="x11,drm"
else
- with_egl_platforms=""
+ with_egl_platforms="x11"
fi
else
AC_MSG_WARN([--with-egl-platforms is deprecated. Use --with-platforms instead.])