summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2015-02-20 12:41:46 -0800
committerMatt Turner <[email protected]>2015-02-20 14:10:38 -0800
commitb21ad12485d24565fd7f21addb5c86c77cf64580 (patch)
tree278e0c3da1e9de54e5890cddd75248c297e2fd5c /configure.ac
parentb6393d70402a60c124c1884d8d0cc1dc6a9b4ca5 (diff)
mesa: Have configure define NDEBUG, not mtypes.h.
mtypes.h had been defining NDEBUG (used by assert) if DEBUG was not defined. Confusing and bizarre that you don't get NDEBUG if you don't include mtypes.h. ... which is just what happened in commit bef38f62e. Let's let configure define this for us if not using --enable-debug. Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index beb7a7d1cfd..5fbb7bc31da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -370,6 +370,8 @@ if test "x$enable_debug" = xyes; then
CXXFLAGS="$CXXFLAGS -O0"
fi
fi
+else
+ DEFINES="$DEFINES -DNDEBUG"
fi
dnl