summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2016-12-01 21:21:10 +0000
committerEmil Velikov <[email protected]>2017-03-15 11:38:05 +0000
commitb1fb6e8d8c059598d08a64bbb90395ad9b14975d (patch)
tree7c5bd007a0550dc3466949c1972279e9324a9663 /configure.ac
parent743315f2696d77bc731baefdc9433994d3a4cfb3 (diff)
anv: do not open random render node(s)
drmGetDevices2() provides us with enough flexibility to build heuristics upon. Opening a random node on the other hand will wake up the device, regardless if it's the one we're interested or not. v2: Rebase, explicitly require/check for libdrm v3: Return VK_ERROR_INCOMPATIBLE_DRIVER for no devices (Ilia) v4: Rebase Cc: Jason Ekstrand <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (v1) Tested-by: Mike Lothian <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a006976a0ca..2adf399c9b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1786,10 +1786,9 @@ if test -n "$with_vulkan_drivers"; then
for driver in $VULKAN_DRIVERS; do
case "x$driver" in
xintel)
- require_libdrm "i965"
+ require_libdrm "ANV"
PKG_CHECK_MODULES([INTEL], [libdrm >= $LIBDRM_INTEL_REQUIRED libdrm_intel >= $LIBDRM_INTEL_REQUIRED])
HAVE_INTEL_VULKAN=yes
-
;;
xradeon)
require_libdrm "radv"