summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVinson Lee <[email protected]>2017-08-05 13:31:50 -0700
committerVinson Lee <[email protected]>2017-08-17 00:11:27 -0700
commita0ed82947c83a64ff8b85bca638e137e5466bd98 (patch)
tree428a666b3680ab5b7adaa005b7ca530e55ae4e8c /configure.ac
parent2c5717a4de2a2406a7e155de641921571a3910c7 (diff)
configure.ac: Check for expat21 if expat is not found.
Fixes build error on CentOS 6.9. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=102052 Fixes: 5c007203b73d ("configure.ac: drop manual detection of expat header/library") Signed-off-by: Vinson Lee <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52645bb44ff..53d52f6d52f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1814,7 +1814,9 @@ if test "x$with_dri_drivers" = xno; then
fi
# Check for expat
-PKG_CHECK_MODULES([EXPAT], [expat])
+PKG_CHECK_MODULES([EXPAT], [expat],,
+ [PKG_CHECK_MODULES([EXPAT], [expat21])]
+)
dnl If $with_dri_drivers is yes, drivers will be added through
dnl platform checks. Set DEFINES and LIB_DEPS