summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichał Górny <[email protected]>2013-12-28 15:22:09 +0100
committerTom Stellard <[email protected]>2014-01-13 14:37:55 -0800
commit5ea23763349346f642d8efdf27e1ea05e9b9e2a8 (patch)
treec65862c031323bb0cd2d222d8f2163ceb21a200c /configure.ac
parent6a19bb56e09e841553ad1295f74fa21bfbbe752a (diff)
Use AC_PATH_TOOL instead of AC_PATH_PROG for llvm-config.
This should help with cross-compiling and multilib when $CHOST-specific llvm-config is expected rather than build host default one. It will help us a bit in Gentoo where we've started using i686-pc-linux-gnu-llvm-config for 32-bit multilib LLVM. Reviewed-by: Tom Stellard <[email protected]> Signed-off-by: Michał Górny <[email protected]> Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=73100 CC: "10.0" <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 475bc6cb6a9..4da6c51d36b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1567,9 +1567,9 @@ if test "x$enable_gallium_llvm" = xauto; then
fi
if test "x$enable_gallium_llvm" = xyes; then
if test "x$llvm_prefix" != x; then
- AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no], ["$llvm_prefix/bin"])
+ AC_PATH_TOOL([LLVM_CONFIG], [llvm-config], [no], ["$llvm_prefix/bin"])
else
- AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no])
+ AC_PATH_TOOL([LLVM_CONFIG], [llvm-config], [no])
fi
if test "x$LLVM_CONFIG" != xno; then