summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-02-07 21:59:14 +0000
committerEmil Velikov <[email protected]>2017-02-10 11:47:23 +0000
commit5869a7db75a144ae898dafe9d9b7cb9d6ae29e12 (patch)
tree3569cf36e356739b5de0accab04fb917be0faf02 /configure.ac
parenta66ffcd736459753a2c3ab73b6c47c66f621fd79 (diff)
configure.ac: move enable-gallium-llvm dependency with-gallium-drivers
... to where it's applicable. Since we effectively made --enable-gallium-llvm mean --enable-llvm with earlier commits, we need to move the requirement to guard the compnents added for the LLVM draw. Otherwise we'll error (as below) when building RADV w/o gallium drivers. configure: error: --enable-gallium-llvm is required when building radv v2: Don't remove but move the dependency (Tobias). Cc: Dave Airlie <[email protected]> Cc: "17.0" <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tobias Droste <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 78b9b0316f0..f43a131ae26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1741,9 +1741,6 @@ AC_ARG_ENABLE([gallium-llvm],
[enable_gallium_llvm="$enableval"],
[enable_gallium_llvm=auto])
-if test -z "$with_gallium_drivers"; then
- enable_gallium_llvm=no
-fi
if test "x$enable_gallium_llvm" = xauto; then
case "$host_cpu" in
i*86|x86_64|amd64) enable_gallium_llvm=yes;;
@@ -2383,7 +2380,7 @@ if test -n "$with_gallium_drivers"; then
done
fi
-if test "x$enable_gallium_llvm" == "xyes"; then
+if test "x$enable_gallium_llvm" == "xyes" -a "$with_gallium_drivers"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
llvm_add_default_components "gallium"
fi