summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2016-10-18 23:19:58 +0200
committerMarek Olšák <[email protected]>2016-10-19 23:19:16 +0200
commit4650a27ba18a5524ca0a9ea3019c35eb2a9c9f43 (patch)
tree91062d0ce7315eec3fde429b8cda806e7b7be756 /configure.ac
parent0e075700fa256c7dacf86cbc91c4a68453cd9558 (diff)
configure.ac: enable GBM by default
Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 9 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b053311e22a..6f6e388caca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -955,9 +955,16 @@ AC_ARG_ENABLE([xa],
[enable_xa=no])
AC_ARG_ENABLE([gbm],
[AS_HELP_STRING([--enable-gbm],
- [enable gbm library @<:@default=auto@:>@])],
+ [enable gbm library @<:@default=yes except cygwin@:>@])],
[enable_gbm="$enableval"],
- [enable_gbm=auto])
+ [case "$host_os" in
+ cygwin*)
+ enable_gbm=no
+ ;;
+ *)
+ enable_gbm=yes
+ ;;
+ esac])
AC_ARG_ENABLE([nine],
[AS_HELP_STRING([--enable-nine],
[enable build of the nine Direct3D9 API @<:@default=no@:>@])],
@@ -1755,14 +1762,6 @@ AC_SUBST([OSMESA_PC_LIB_PRIV])
dnl
dnl gbm configuration
dnl
-if test "x$enable_gbm" = xauto; then
- case "$with_egl_platforms" in
- *drm*)
- enable_gbm=yes ;;
- *)
- enable_gbm=no ;;
- esac
-fi
if test "x$enable_gbm" = xyes; then
if test "x$enable_dri" = xyes; then
if test "x$enable_shared_glapi" = xno; then