summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-06-05 00:03:59 +0100
committerEmil Velikov <[email protected]>2017-06-15 23:24:26 +0100
commite5aa806e5f01b842d1af4775f8e4c53282908304 (patch)
treefe80b396913327e4345565556b656de3ec2f4392 /configure.ac
parentfcbb93e860246375d03f280f927f79d3645a8988 (diff)
configure.ac: add -pthread to PTHREAD_LIBS
As described inline - follow what's written in the manual and what works for all platforms that Mesa supports. We want to untangle things leaving only -pthread, yet that has a potential of causing regressions. Thus we'll do it as a follow-up patch. As a nice side-effect this resolves issues, where the system lacks libpthread.so, yet the linker does not warn about it and we and up with unresolved symbols. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=101071 Cc: [email protected] Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2eed43615aa..9b1c43a5b62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -837,6 +837,11 @@ dnl is not valid for that platform.
if test "x$android" = xno; then
test -z "$PTHREAD_LIBS" && PTHREAD_LIBS="-lpthread"
fi
+dnl According to the manual when using pthreads, one should add -pthread to
+dnl both compile and link-time arguments.
+dnl In practise that should be sufficient for all platforms, since any
+dnl platforms build with GCC and Clang support the flag.
+PTHREAD_LIBS="$PTHREAD_LIBS -pthread"
dnl pthread-stubs is mandatory on BSD platforms, due to the nature of the
dnl project. Even then there's a notable issue as described in the project README