summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChad Versace <[email protected]>2014-01-07 12:08:30 -0800
committerChad Versace <[email protected]>2014-02-05 18:19:26 -0800
commit1340e24406fbdfdbfb49dc19d7d5d72d6e363631 (patch)
tree09545176bdfa21dcf9a4ce9a548ea92328d8b465 /configure.ac
parent0224bd20f391e8e26637380bb50187ba2fb51ee4 (diff)
egl/glx: Remove egl_glx driver
Mesa now has a real, feature-rich EGL implementation on X11 via xcb. Therefore I believe there is no longer a practical need for the egl_glx driver. Furthermore, egl_glx appears to be unmaintained. The most recent nontrivial commit to egl_glx was 6baa5f1 on 2011-11-25. Tested by running weston-smoke in windowed Weston on X with i965. Signed-off-by: Chad Versace <[email protected]> Acked-by: Kenneth Graunke <[email protected]> Acked-by: Kristian Høgsberg <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index ba158e8accf..9bc7a72540b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1206,8 +1206,6 @@ if test "x$enable_egl" = xyes; then
AC_CHECK_FUNC(mincore, [DEFINES="$DEFINES -DHAVE_MINCORE"])
if test "$enable_static" != yes; then
- # build egl_glx when libGL is built
-
if test "x$enable_dri" = xyes; then
HAVE_EGL_DRIVER_DRI2=1
fi
@@ -1440,10 +1438,6 @@ for plat in $egl_platforms; do
x11)
PKG_CHECK_MODULES([XCB_DRI2], [x11-xcb xcb-dri2 >= 1.8 xcb-xfixes])
-
- if test "x$enable_glx" = xyes; then
- HAVE_EGL_DRIVER_GLX=1
- fi
;;
drm)
@@ -1486,7 +1480,6 @@ AM_CONDITIONAL(HAVE_EGL_PLATFORM_FBDEV, echo "$egl_platforms" | grep 'fbdev' >/d
AM_CONDITIONAL(HAVE_EGL_PLATFORM_NULL, echo "$egl_platforms" | grep 'null' >/dev/null 2>&1)
AM_CONDITIONAL(HAVE_EGL_DRIVER_DRI2, test "x$HAVE_EGL_DRIVER_DRI2" != "x")
-AM_CONDITIONAL(HAVE_EGL_DRIVER_GLX, test "x$HAVE_EGL_DRIVER_GLX" != "x")
AC_SUBST([EGL_NATIVE_PLATFORM])
AC_SUBST([EGL_CFLAGS])
@@ -1976,7 +1969,6 @@ AC_CONFIG_FILES([Makefile
src/egl/Makefile
src/egl/drivers/Makefile
src/egl/drivers/dri2/Makefile
- src/egl/drivers/glx/Makefile
src/egl/main/Makefile
src/egl/main/egl.pc
src/egl/wayland/Makefile
@@ -2158,9 +2150,6 @@ if test "$enable_egl" = yes; then
echo " EGL platforms: $egl_platforms"
egl_drivers=""
- if test "x$HAVE_EGL_DRIVER_GLX" != "x"; then
- egl_drivers="$egl_drivers builtin:egl_glx"
- fi
if test "x$HAVE_EGL_DRIVER_DRI2" != "x"; then
egl_drivers="$egl_drivers builtin:egl_dri2"
fi