summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBoyan Ding <[email protected]>2015-07-21 23:44:00 +0800
committerMartin Peres <[email protected]>2015-11-17 17:26:20 +0200
commitf35198badeb956a8f435727d805a47c7e42610d0 (patch)
tree055cc089ff20ad8101c632f4c2d9612f1c7684bf /configure.ac
parenta25df5457121d40fef86929d4c10d8058a4d5c72 (diff)
egl/x11: Implement dri3 support with loader's dri3 helper
v2: From Martin Peres - Tell we are compiling the dri3 backend in configure.ac - Update the Makefile.am - get rid of the LIBDRM_HAS_RENDERNODE_SUPPORT macro - fix some warnings related to EGLuint64KHR to int64_t conversions - use dri2_get_dri_config to get the __DRIconfig instead of open-coding it - replace the occasional tabs with spaces v3: From Martin Peres - fix and indent problem (Matt Turner) - drop the authenticate function, use NULL in the vtable instead (Emil) - drop some useless includes (Emil Velikov) - mandate libdrm (Emil Velikov) - link to xcb-dri3 (Kristian Høgsberg) - convert to the new loader interface for drwable (Kristian) - remove some dead code after the dropping of some vfuncs (Kristian) - add a comment on the topic of rendering to the frontbuffer v4: From Martin Peres - do not expose the preserved swap behavior (Acked by Eric Anholt) Signed-off-by: Boyan Ding <[email protected]> Signed-off-by: Martin Peres <[email protected]> Reviewed-by: Kristian Høgsberg <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ea9ab22346..32fb989a898 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1568,6 +1568,12 @@ if test "x$enable_egl" = xyes; then
if test "x$enable_shared_glapi" = xno; then
AC_MSG_ERROR([egl_dri2 requires --enable-shared-glapi])
fi
+ if test "x$enable_dri3" = xyes; then
+ HAVE_EGL_DRIVER_DRI3=1
+ if test "x$enable_shared_glapi" = xno; then
+ AC_MSG_ERROR([egl_dri3 requires --enable-shared-glapi])
+ fi
+ fi
else
# Avoid building an "empty" libEGL. Drop/update this
# when other backends (haiku?) come along.
@@ -2520,6 +2526,9 @@ if test "$enable_egl" = yes; then
if test "x$HAVE_EGL_DRIVER_DRI2" != "x"; then
egl_drivers="$egl_drivers builtin:egl_dri2"
fi
+ if test "x$HAVE_EGL_DRIVER_DRI3" != "x"; then
+ egl_drivers="$egl_drivers builtin:egl_dri3"
+ fi
echo " EGL drivers: $egl_drivers"
fi